Plus de clavier au démarrage du Mac

Les symptômes

 

Je vous avoue avoir eu un petit moment de panique tout à l’heure lorsque j’ai redémarré mon macbook (parce qu’il faut bien de temps en temps quand même) !! Je passerai sur le fait qu’il ne s’est pas éteint totalement correctement… Mais c’est au redémarrage, aussitôt le son passé (FileVault est actvé sur mon mac, je dois donc être identifié avant le boot de MacOS), lorsqu’il a fallu que je clique que l’icône de mon compte et que je saisisse mon mot de passe … PAN !! : Impossible de faire quoique ce soit avec le clavier du mac pas plus qu’avec le trackpad…

Après quelques redémarrages, je teste ma magic mouse et là, miracle j’ai récupéré la souris mais toujours pas de clavier…
Très étrange, cela doit donc être lié à une constation que j’avais faite avant d’éteindre le mac : la connexion bluetooth avec mon clavier sans fil, pourtant situé à 7 km de là, est toujours active. Coincidence ? Toujours est-il que seuls les périphériques bluetooth sont utilisables et je suis donc bloqué pour la saisie du mot de passe.

La solution ?

 

Dans mon cas, un vidage de la PRAM (Mémoire vive des paramètres) a réglé le problème, pour ce faire : au redémarrage de l’ordinateur, il faut maintenir appuyer les touches Commande + Alt (Option) + P + R, le mac reboote au bout de quelques secondes et hop, c’est réglé (en tout cas dans mon cas)…

D’après les informations que j’ai récupéré, cette PRAM stocke des infos sur la configuration (mais pas ce qui concerne le réseau) et les périphériques du Mac. Sa réinitialisation permet donc de régler un certain nombre de problème.
Il y a plus de détails sur le site du support d’Apple concernant le contenu de cette mémoire PRAM.

Concernant la réinitialisation de la PRAM, plus d’infos sur le site du support Apple ou sur cette news de Macgeneration.

La boîte GMail buggée sur iPhone / iPad

Depuis quelques semaines, ma boîte gmail sur l’appui mail de mon iPhone se comportait bizarrement : désactivation / réactivation du compte sur le téléphone, passage à iOS 5.1, rien à faire, toujours les mêmes symptômes.

Ces symptômes étaient les suivants :

  • une boîte de réception inaccessible depuis la liste des boîtes de réception avec l’obligation de passer par les comptes : donc des petits clics supplémentaires et une ergonomie devenant vraiment moins géniale.
  • Une présentation des dossiers avec deux dossiers « Boîte de réception » (cf. ci-contre), pas très grave mais c’était clairement le signe d’un problème.
  • et surtout plus de possibilité d’archiver les mails mais obligation de les effacer, et ça, c’est beaucoup moins pratique, surtout pour les mails dans les conversations : la mise en corbeille d’un mail d’une conversation à tendance à supprimer toute la conversation.
La solution pour retrouver sa boîte mail comme neuve sur son smartphone préféré est à rechercher du côté du webmail gmail (http://mail.google.com) :
  • Connectez-vous à votre boîte mail
  • Allez dans les préférences -> Libellés
  • Et vérifier que la case à cocher « Afficher en IMAP » est effectivement cochée pour les libellés « Messages envoyés », « Brouillons », « Tous les messages » et « Corbeille » (cf. capture du paramétrage sur ma boîte ci-dessous)
Et voilà, la boîte mail se comporte à nouveau normalement.

Coupure réseau : à qui la faute ?

Ce matin, nous avons eu, au support de notre boite, plusieurs coup de fil de clients ne pouvant accéder à leur site.
Nous testons de notre côté, pas de problème : les serveurs fonctionnent correctement, pas de charge particulière, la connexion est bonne. Après un peu de recherche, la piste d’un défaut entre certains réseau de nos clients et celui de notre hébergeur, OVH, est confirmé, sur le site des incidents et maintenances en cours, nous découvrons qu’un problème de peering chez SFINX est à l’origine de ces problèmes.

Continuer la lecture de « Coupure réseau : à qui la faute ? »

Nginx et les erreurs 413

Après quelques semaines d’utilisation de Nginx comme serveur web support de ce blog, me voilà confronté à un étrange problème : des erreurs HTTP 413 Request Entity Too Large.
Pourtant le média importé est inférieur à la limite d’upload fixée dans PHP.

Et pour cause, le message d’erreur est une erreur HTTP qui provient directement de Nginx. Un petit coup d’oeil sur le net et dans la doc de Nginx donne la solution : il s’agit de la directive client_max_body_size qui par défaut est à 1 Mo.
Elle s’utilise dans les contexte http, server ou location (on peut donc logiquement définir une taille max par vhost, ou par site par ex.)

Voili voilou, plus d’info dans la documentation de Nginx.

Attention aux mises à jour iPhone OS 4

Voici un billet sous forme d’avertissement : depuis un mois que j’ai mis mon iPhone 3G (pas S) à jour avec l’iPhone OS 4, je le regrette globalement.
Les nouveautés sont certes assez sympa mais de toutes façons sur un iPhone 3G, la principale évolution qu’est le multi-tâches, n’est pas disponible (il faut avoir un iPhone 3GS ou 4 pour en bénéficier).
Mais surtout au-delà de tout cela, c’est que cette mise à jour de l’OS le rend plus gourmand et que de mon retour d’expérience, un 3G, c’est pas assez costaud pour le supporter. Parmi les déconvenues :

  • ça raaaaame comme pas possible, voire l’appli se coupe et on revient au menu principal
  • ça nuit gravement à l’utilisation du bousin, vu que parfois, c’est même décrocher qui est impossible, pour peu qu’on était entrain d’écouter de la zik et d’envoyer un sms, comme l’iPhone est en galère, le slide pour répondre à l’appel est freezé.

Bref, je ne sais si je suis un cas isolé mais je recommande de ne surtout pas faire de mise à jour vers l’iOS 4 sur un iPhone 3G simple.

EDIT 11/09/2010 : La mise à jour de l’iOS 4.1 disponible depuis cette semaine règle ce problème, on retrouve un niveau d’utilisation de l’iOS 3 (bien que cela reste moins rapide qu’avec un iPhone 3GS, mais c’est logique).
Cette mise à jour avait été annoncée par Apple pour notamment résoudre les problèmes d’occupation mémoire et lenteurs sur les iPhones 3G de base.

Problème de connexion à last.fm depuis Rythmbox

Depuis mon passage à Lucid Lynx (la release Ubuntu estampillée 10.04), je réutilise le lecteur musical natif à Rythmbox qui a bien évolué depuis Jaunty et Karmic et ne semble plus freezer ma machine dès que j’ai une bibliothèque musicale un peu longue.

A la suite d’une réinstallation de mon système, je découvre, très embêté, que lorsque j’essaie de configurer le greffon (plug-in) last.fm sur mon rythmbox, j’ai systématiquement le message d’erreur suivant : Nom d’utilisateur et/ou mot de passe incorrect.
En fait, la solution (trouvée sur le forum Rythmbox de last.fm) est de saisir son identifiant et son mot de passe puis de valider par la touche TAB (pour changer de champ) et non pas ENTREE.

Très très sioux, mais ça marche !!

En espérant que ça puisse aider…

Le nouveau blog, la tête dans les nuages

Après avoir laissé hiberner de longs mois ce blog, il m’a fallu, pour le relancer, répondre à cette question : quel hébergement pour remettre en route le petit pépère ?
En effet, l’objectif est aussi pour moi de pouvoir tester de nouvelles technologies, os, type d’hébergement…

Continuer la lecture de « Le nouveau blog, la tête dans les nuages »

Quand le gestionnaire de paquet fait des siennes…

Petite news technique : tout commence Jeudi soir dans le train lorsque au redémarrage de mon PC sous Ubuntu 8.10 (Intrepid Ibex) : au démarrage de Gnome, la moitié de mes éléments de mes tableaux de bords ne s’affiche pas.

Plus embêtant, mon gestionnaire de paquets m’avertit d’un message pour le moins abrupt :

Lecture des listes de paquets... Erreur ! E: Erreur de lecture - read (5 Erreur d'entrée/sortie) E: Les listes de paquets ou le fichier « status » ne peuvent être analysés ou lus.

Bref, après un petit tour des les forums Ubuntu, la solution réside dans une mise à jour de la liste des paquets via un :

sudo apt-get update

Ca remarche nickel !!